Writing King2
SEE ATTACHMENTS
Interface names may vary among network device types. The interface names shown in the topology image are consistent with those found in the lab activity document. Use the IOS show interface and show controllers commands to determine the actual interface names for the devices used in the lab pod.
When you have completed the activities, answer the questions that are within the individual labs in a Word Document. Within your submission, include your completed Lab Assignment Report. Save and name your file, "CIS204_U2_LabAssignment_LastName.docx".
You must complete the activities in the following order:
Lab 7.1.4.8: Configuring OSFPv2 Advanced Features
Configuring OSFPv2 Advanced Features
Lab 4.2.2.5: Configuring Basic EIGRP for IPV4
Configuring Basic EIGRP for IPV4
Lab 5.1.5.5: Configuring Advanced EIGRP for IPv4 Features
Configuring Advanced EIGRP for IPv4 Features
Lab 5.2.3.7: Troubleshooting Advanced EIGRP
Troubleshooting Advanced EIGRP
Lab 7.2.3.4: Troubleshooting Advanced Single-Area OSPFv2
Troubleshooting Advanced Single-Area OSPFv2
© 2013 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 1 of 9
Lab – Troubleshooting Advanced EIGRP
Topology
Lab – Troubleshooting Advanced EIGRP
© 2013 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 2 of 9
Addressing Table
Device Interface IP Address Subnet Mask Default Gateway
R1 G0/0 192.168.1.1 255.255.255.0 N/A
Lo1 172.16.11.1 255.255.255.0 N/A
Lo2 172.16.12.1 255.255.255.0 N/A
Lo3 172.16.13.1 255.255.255.0 N/A
Lo4 172.16.14.1 255.255.255.0 N/A
S0/0/0 (DCE) 192.168.12.1 255.255.255.252 N/A
S0/0/1 192.168.13.1 255.255.255.252 N/A
R2 G0/0 192.168.2.1 255.255.255.0 N/A
Lo0 209.165.200.225 255.255.255.252 N/A
S0/0/0 192.168.12.2 255.255.255.252 N/A
S0/0/1 (DCE) 192.168.23.1 255.255.255.252 N/A
R3 G0/0 192.168.3.1 255.255.255.0 N/A
Lo3 172.16.33.1 255.255.255.0 N/A
Lo4 172.16.34.1 255.255.255.0 N/A
Lo5 172.16.35.1 255.255.255.0 N/A
Lo6 172.16.36.1 255.255.255.0 N/A
S0/0/0 (DCE) 192.168.13.2 255.255.255.252 N/A
S0/0/1 192.168.23.2 255.255.255.252 N/A
PC-A NIC 192.168.1.3 255.255.255.0 192.168.1.1
PC-B NIC 192.168.2.3 255.255.255.0 192.168.2.1
PC-C NIC 192.168.3.3 255.255.255.0 192.168.3.1
Objectives
Part 1: Build the Network and Load Device Configurations
Part 2: Troubleshoot EIGRP
Background / Scenario
The Enhanced Interior Gateway Routing Protocol (EIGRP) has advanced features to allow changes related to summarization, default route propagation, bandwidth utilization, metrics, and security.
In this lab, you will troubleshoot a network that is running EIGRP. Advanced EIGRP features have been implemented, but the network is now experiencing problems. You are tasked with finding and correcting the network issues.
Note: The routers used with CCNA hands-on labs are Cisco 1941 Integrated Services Routers (ISRs) with Cisco IOS, Release 15.2(4)M3 (universalk9 image). Other routers and Cisco IOS versions can be used. Depending on the model and Cisco IOS version, the commands available and output produced might vary
Lab – Troubleshooting Advanced EIGRP
© 2013 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 3 of 9
from what is shown in the labs. Refer to the Router Interface Summary Table at the end of this lab for the correct interface identifiers.
Note: Ensure that the routers have been erased and have no startup configurations. If you are unsure, contact your instructor.
Required Resources
3 Routers (Cisco 1941 with Cisco IOS Release 15.2(4)M3 universal image or comparable)
3 PCs (Windows 7, Vista, or XP with terminal emulation program, such as Tera Term)
Console cables to configure the Cisco IOS devices via the console ports
Ethernet cables as shown in the topology
Part 1: Build the Network and Load Device Configurations
Step 1: Cable the network as shown in the topology.
Step 2: Configure PC hosts.
Step 3: Load router configurations.
Load the following configurations into the appropriate router. All routers have the same passwords. The privileged EXEC password is class, and cisco is the console and vty password.
Router R1 Configuration:
conf t
hostname R1
enable secret class
no ip domain lookup
key chain EIGRP-KEYS
key 1
key-string cisco123
line con 0
password cisco
login
logging synchronous
line vty 0 4
password cisco
login
banner motd @
Unauthorized Access is Prohibited! @
interface lo1
description Connection to Branch 11
ip add 172.16.11.1 255.255.255.0
interface lo2
description Connection to Branch 12
ip add 172.16.12.1 255.255.255.0
interface lo3
Lab – Troubleshooting Advanced EIGRP
© 2013 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 4 of 9
description Connection to Branch 13
ip add 172.16.13.1 255.255.255.0
interface lo4
description Connection to Branch 14
ip add 172.16.14.1 255.255.255.0
interface g0/0
description R1 LAN Connection
ip add 192.168.1.1 255.255.255.0
no shutdown
interface s0/0/0
description Serial Link to R2
clock rate 128000
ip add 192.168.12.1 255.255.255.252
ip authentication mode eigrp 1 md5
ip authentication key-chain eigrp 1 EIGRP-KEYS
ip hello-interval eigrp 1 30
ip hold-time eigrp 1 90
ip bandwidth-percent eigrp 1 40
no shutdown
interface s0/0/1
description Serial Link to R3
bandwidth 128
ip add 192.168.13.1 255.255.255.252
ip authentication mode eigrp 1 md5
ip authentication key-chain eigrp 1 EIGRP-KEYS
ip bandwidth-percent eigrp 1 40
no shutdown
router eigrp 1
router-id 1.1.1.1
network 192.168.1.0 0.0.0.255
network 192.168.12.0 0.0.0.3
network 192.168.13.0 0.0.0.3
network 172.16.0.0 0.0.255.255
passive-interface g0/0
auto-summary
end
Router R2 Configuration:
conf t
hostname R2
enable secret class
no ip domain lookup
key chain EIGRP-KEYS
key 1
key-string Cisco123
line con 0
Lab – Troubleshooting Advanced EIGRP
© 2013 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 5 of 9
password cisco
login
logging synchronous
line vty 0 4
password cisco
login
banner motd @
Unauthorized Access is Prohibited! @
interface g0/0
description R2 LAN Connection
ip add 192.168.2.1 255.255.255.0
no shutdown
interface s0/0/0
description Serial Link to R1
bandwidth 128
ip add 192.168.12.2 255.255.255.252
ip authentication mode eigrp 1 md5
ip authentication key-chain eigrp 1 EIGRP-KEYS
ip bandwidth-percent eigrp 1 40
ip hello-interval eigrp 1 30
ip hold-time eigrp 1 90
no shutdown
interface s0/0/1
description Serial Link to R3
bandwidth 128
ip add 192.168.23.1 255.255.255.252
ip authentication mode eigrp 1 md5
ip bandwidth-percent eigrp 1 40
ip hello-interval eigrp 1 30
ip hold-time eigrp 1 90
no shutdown
interface lo0
ip add 209.165.200.225 255.255.255.252
description Connection to ISP
router eigrp 1
router-id 2.2.2.2
network 192.168.2.0 0.0.0.255
network 192.168.12.0 0.0.0.3
network 192.168.23.0 0.0.0.3
passive-interface g0/0
ip route 0.0.0.0 0.0.0.0 lo0
end
Router R3 Configuration:
conf t
hostname R3
Lab – Troubleshooting Advanced EIGRP
© 2013 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 6 of 9
enable secret class
no ip domain lookup
key chain EIGRP-KEYS
key 1
key-string Cisco123
line con 0
password cisco
login
logging synchronous
line vty 0 4
password cisco
login
banner motd @
Unauthorized Access is Prohibited! @
interface lo3
description Connection to Branch 33
ip add 172.16.33.1 255.255.255.0
interface lo4
description Connection to Branch 34
ip add 172.16.34.1 255.255.255.0
interface lo5
description Connection to Branch 35
ip add 172.16.35.1 255.255.255.0
interface lo6
description Connection to Branch 36
ip add 172.16.36.1 255.255.255.0
interface g0/0
description R3 LAN Connection
ip add 192.168.3.1 255.255.255.0
no shutdown
interface s0/0/0
description Serial Link to R1
ip add 192.168.13.2 255.255.255.252
ip authentication mode eigrp 1 md5
ip authentication key-chain eigrp 1 EIGRP-KEYS
ip hello-interval eigrp 1 30
ip hold-time eigrp 1 90
clock rate 128000
bandwidth 128
no shutdown
interface s0/0/1
description Serial Link to R2
bandwidth 128
ip add 192.168.23.2 255.255.255.252
ip authentication mode eigrp 1 md5
Lab – Troubleshooting Advanced EIGRP
© 2013 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 7 of 9
ip authentication key-chain eigrp 1 eigrp-keys
! ip bandwidth-percent eigrp 1 40
ip hello-interval eigrp 1 30
ip hold-time eigrp 1 90
no shutdown
router eigrp 1
router-id 3.3.3.3
network 192.168.3.0 0.0.0.255
network 192.168.13.0 0.0.0.3
network 192.168.23.0 0.0.0.3
network 172.16.0.0 0.0.255.255
passive-interface g0/0
auto-summary
end
Step 4: Verify end-to-end connectivity.
Note: It may be necessary to disable the PC firewall to ping between PCs.
Step 5: Save the configuration on all routers.
Part 2: Troubleshoot EIGRP
In Part 2, verify that all routers have established neighbor adjacencies, and that all network routes are available.
Additional EIGRP Requirements:
All serial interface clock rates should be set at 128 Kb/s and a matching bandwidth setting should be
available to allow EIGRP cost metrics to be calculated correctly.
Manual route summarization of the branch networks, simulated by using Loopback interfaces on R1 and
R3, should be utilized. The automatic summarization feature of EIGRP should not be used.
EIGRP should redistribute the static default route to the Internet. This is simulated by using Loopback
interface 0 on R2.
EIGRP should be configured to use no more than 40 percent of the available bandwidth on the serial
interfaces.
EIGRP Hello/Hold timer intervals should be set to 30/90 on all serial interfaces.
All serial interfaces should be configured with MD5 authentication, using key chain EIGRP-KEYS, with a
key-string of Cisco123.
List the commands used during your EIGRP troubleshooting process:
Lab – Troubleshooting Advanced EIGRP
© 2013 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 8 of 9
List the changes made to resolve the EIGRP issues. If no problems were found on the device, then respond with “no problems were found”.
R1 Router:
R2 Router:
R3 Router:
Reflection
1. How can the auto-summary command create routing issues in EIGRP?
2. What advantages are provided by manually summarizing the branch routes (loopback interfaces on R1 and R3) in this network?
3. Why would you want to change the EIGRP Hello and Hold time intervals on an interface?
Lab – Troubleshooting Advanced EIGRP
© 2013 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 9 of 9
Router Interface Summary Table
Router Interface Summary
Router Model Ethernet Interface #1 Ethernet Interface #2 Serial Interface #1 Serial Interface #2
1800 Fast Ethernet 0/0 (F0/0)
Fast Ethernet 0/1 (F0/1)
Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
1900 Gigabit Ethernet 0/0 (G0/0)
Gigabit Ethernet 0/1 (G0/1)
Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
2801 Fast Ethernet 0/0 (F0/0)
Fast Ethernet 0/1 (F0/1)
Serial 0/1/0 (S0/1/0) Serial 0/1/1 (S0/1/1)
2811 Fast Ethernet 0/0 (F0/0)
Fast Ethernet 0/1 (F0/1)
Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
2900 Gigabit Ethernet 0/0 (G0/0)
Gigabit Ethernet 0/1 (G0/1)
Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
Note: To find out how the router is configured, look at the interfaces to identify the type of router and how many interfaces the router has. There is no way to effectively list all the combinations of configurations for each router class. This table includes identifiers for the possible combinations of Ethernet and Serial interfaces in the device. The table does not include any other type of interface, even though a specific router may contain one. An example of this might be an ISDN BRI interface. The string in parenthesis is the legal abbreviation that can be used in Cisco IOS commands to represent the interface.
TextField1: